Start a new topic
Answered

Timeline cannot be loaded into Styly scene (AR)

Hi,


I’m having a problem with the timeline and looking for some help.
I’m trying to activate images or videos from the timeline. See the attached screen recording for what I’m trying to do.
It worked ok when playing in Unity, uploaded successfully in Styly.
When I try to load the timeline (called StoryTest) into the Styly scene, it keeps loading… (see attached screenshot).
I checked the file size of StoryTest (timeline) prefab and it is 8MB so it’s within the size limit.
I encounter this problem when I tried to include images or videos in the timeline so far.


Any suggestions would be much appreciated!

mov

Best Answer

Hi, Tomomi Tomlin


I figured out what the problem was.

The reason for the infinite load seems to be that you are uploading a prefab that is initially inactive (no check next to the name of the inspector in unity).

Therefore, it would be better to upload active prefabs and implement the appearance gimmick in a timeline.


However, due to a bug in Unity, the VideoPlayer is currently not displayed in the WebGL version.

The bug is scheduled to be fixed soon, so as long as it's after that, the video will show up.


Sincerely,


Hi, Tomomi


It will take roughly two months for the bug in VideoPlayer to be fixed.


Kind regards,


1 person likes this

Thanks for the confirmation, it turns out it's not a temporary stop of the STYLY scene.


Here's another idea: your Unity version might be different from the Unity version STYLY recommends.

STYLY recommends Unity 2019. Timelines created in earlier Unity versions, such as Unity 2017, will not work on STYLY scene.

Please check your Unity version.


Thank you.

Hi Hara-san,


Thank you for looking into the issue.

The timeline isn't placed in the scene after reloading it. See an attached video.


Thanks,

Tomomi

mov

Hi Hara-san,


Thanks for the response. Please see the attached copy of the screenshots.

Playmaker - the flow of playmaker and it activates the timeline

Timeline - it activates the video. The animator track does nothing - I tried to delete it but couldn't...


Regards,

Tomomi

Timeline.png
(634 KB)

Hi Hara-san,


I've uploaded the scene but the timeline part didn't work in Styly (other actions in Playmaker worked) although it was working in Unity play mode. 


Thanks for looking into this.

Regards,

Tomomi

Hi Hara-san,


Thank you for the resolution and the information.

I will make the change suggested in your comment and test it.


Do you have information on when the bug in VideoPlayer will be fixed?


Regards,

Tomomi

Thank you so much for the help, Hara-san!

Dear Tomomi,

Thank you for using STYLY. 


I checked your image and video.

Try reloading the page, and reopening the scene. The file size is fine, but the scene may have stopped temporarily.

If the timeline is not placed in the scene after reloading, please let me know in a reply.


Sincerely yours,

Thank you for looking into the issue.

The version of Unity is 2019.3.6f1 - I believe it is the recommended version for Styly?

Would it be helpful if I send you Unity project file?


Regards,

Tomomi

Dear Tomomi Tomlin, 


I'd like to check your Unity project, and could you send your Unity project to following mail address?

info@styly.cc


I appreciate your time.

Thank you, your Unity version is proper, so it's not a problem.


I'd like to check your timeline, so could you show me screenshots of timeline window?

Hi, thank you for your check.


It could be a problem with the STYLY system, so I'll ask the technical team. I'll write in this reply as soon as I know the situation.


Sincerely yours,

Dear Tomomi,


Thank you for explaining the situation in detail.

I checked your Unity scene, but it doesn't look like there's a problem.


Can you try to upload it as a scene instead of a prefab upload?

This manual is how to upload as a scene

https://styly.cc/manual/unity-asset-uploader/

If it still doesn't work, I will consult with the technical team as it could be a STYLY system error.


Sincerely yours,

Answer

Hi, Tomomi Tomlin


I figured out what the problem was.

The reason for the infinite load seems to be that you are uploading a prefab that is initially inactive (no check next to the name of the inspector in unity).

Therefore, it would be better to upload active prefabs and implement the appearance gimmick in a timeline.


However, due to a bug in Unity, the VideoPlayer is currently not displayed in the WebGL version.

The bug is scheduled to be fixed soon, so as long as it's after that, the video will show up.


Sincerely,

Login or Signup to post a comment