Start a new topic

How to put a sphere environment into a STYLY scene

 I was trying to put a giant textured sphere that would encapsulate my VR scene in STYLY, but it doesn't seem to work. The sphere is always transparent on the inside. I tried different textures/shaders but it doesn't seem to matter. How can i fix this?

1 Comment

Hi There

This issue is caused by a setting called "backface culling," which unfortunately can not be turned off in STYLY. Backface culling makes it so the inside of shapes are transparent which saves computation for rendering and lighting. You can also see this whenever you look at the backside of a plane.

However there is a solution for your problem!

To create a sphere where the interior renders, you need to flip the faces (aka normals) of your sphere so that they face inwards.

You can do this in many different pieces of 3d software, check out this demo of how to flip normals in Blender which is free to use.

1 person likes this
Login or Signup to post a comment