Start a new topic

Failed to receive data when trying to upload scene to STYLY

hello there,

my question is that when i'm tryin to upload my scene to STYLY, it do show that ''Upload success'',but when enter the Launch STYLY, i couldn't find my scene. Instead, it shows the message below in Unity

Failed to receive data


Can i just ask what is the meaning of that and how can i fix it?
thanks a lot !

(btw my API key is successfully linked. And i can upload a 3d model.(scene can't)QQ)

Best Answer

I'm glad to hear that you could solve the problem.


Dear trissy,

Thank you for using STYLY.

I want to check following 2 situations.

1. What is your Unity version? STYLY Plugin for Unity is compatible with Unity 2019.

2. Are the required modules installed? In order to use the STYLY Plugin for Unity, there are some modules that need to be installed in Unity beforehand.

If the module is not installed, an error message will be displayed in red letters in the setting window as shown below.

If you have already done the above settings correctly, please let me know in a reply.

Sincerely yours,


(12.2 KB)

1 person likes this

thanks for your reply!!

1. My Unity version is 2019.3.6f1
2.I have downloaded the link that shows in the web, and there is no red letters in the setting window

so I think I have already done the above settings QQ 

Thank you for your checking. There are no problems on your Unity version and modules.

I tried scene upload, and it worked well on both STYLY Studio and Unity. Therefore, the function of scene upload may not have any problems.

In order to find the cause of the problem, please upload a simple scene with just one cube to STYLY. If you still get the error, the cause of the problem would be settings about Unity. If you can upload the simple scene without any errors, the cause of the problem would be about objects in your Unity scene.

Let me know the results, and I'll come up with a plan for improvement.

Best regards,

1 person likes this

Dear Hara,

There is no problem when I upload a simple scene, so I think it should be about my objects.

The thing is, I'm using Playmaker on my objects, and I read about an article ( ) indicates that I should ''Use Playmaker version 1.8.x'' I then check my PlayMaker version, it is 1.9.0.p20, which is the version that my computer indicate me to download in the first place.

but I don't know how to switch it back to version 1.8.x, or do you think this shouldn't be that much of a problem?

And I also read about ''Transactions between multiple FSM’s are not usable''

Is this means that It can't happen '' two things keep on moving in the same time ''?

I don't really understand the meaning @@ sorry but can you explain it more plz

Cause in my scene, I made a cylinder keep on rotating when TRIGGER ENTER(It uploads to styly successfully), and when I duplicate that cylinder(Now there are two cylinder with PlayMaker added), then upload, it Failed.(I didn't do any other setting between these steps) So I was wondering is that a wrong move ? 

Thank you so much for your time

Dear Trissy,

Thank you for your detailed explanation. I may have found the cause of your problem.

At first, your PlayMaker version is proper and you don't have to switch back to version 1.8.x.

The description of the article is old, and I will update it. Thank you!

Second, ''Transactions between multiple FSM’s are not usable' means that STYLY does not support playmaker's global variables.

Please refer following article for detail.

Third, this point may be the cause of your error.

You duplicated not only the cylinder but also PlayMaker action. The newer cylinder's PlayMaker action should be set to run the older cylinder. 

Check the settings of the newer PlayMaker action to make sure it is not exactly the same as the older PlayMaker action.

If you don't understand it, please show me pictures of the newer PlayMaker action setup screen and the older PlayMaker action setup screen.

oh!!!!  I understand and I have fixed the duplicate problem !

Thanks a lot!

although when I continue to build up my scene, there is this error coming out again QQ
which I'm sure that I didn't do anything such as duplicate the whole object that contains PlayMaker

The new moves that I've done were
 (things that happened between successfully uploaded and Failed to receive data error )

1.Changing the Lighting - Environment - Skybox Material to something I downloaded from Unity Asset Store, and change the Sun Source in to None(Light), then change the Lightmapping settings - Direct Samples to 8, Indirect samples to 16, Environment samples to 16.

2. Adding some point lights that contain PlayMaker '' Sensor Light '' action.
(which I do upload them successfully during the making at some point, but I then made some changes after building up the FSM such as moving the Point lights position and changing its' Range and Intensity)

while not sure what is causing the error, I do try to uncheck all the point lights I new make from the inspector window then try to upload, but the error remains showing up QQ

these are the two main changes that I remember clearly, but I'm not sure if there's some move that I forget to mention QQ
therefore I'm sending my project to
name as ''Failed to receive data when trying to upload scene to STYLY ''
I though that this might be more clear and direct !!


(174 KB)

oh ! there's one more moves

I was trying to import '' ReadyPlayerMe's '' avatars, and add '' in place walking '' animation import from Mixamo


3. I import the '' Ready Player Me - Avatar Loader '' in my project, I was going to use it, but then I've change my plan to only use the Mixamos' characters and animations, so I've remove the avatar from Ready Player Me. 
(I'm not sure is ReadyPlayerMes' existence effects anything ? QQ)

thanks   :pray:

Hi, trissy

I checked your email. You have uploaded your Unity project directly to Drive, but the file size is too large to download.

Is it possible to re-upload the file in unitypackage format?

Best regards,

Oh ! Sorry about that !

Although during these days,  I've solved the problem by simply changing the Network @@!
(I changed from homes' WIFI to  my phone's personal hotspot)
How weird XD
But still, thanks a lot !!!


I'm glad to hear that you could solve the problem.


Login or Signup to post a comment